We have determined that the incident was caused by a Firewall configuration, and it has now been resolved and UI is fully operational
Posted Jun 26, 2025 - 15:32 UTC
Investigating
The app.labra.io UI is currently down. We are actively working on finding the root cause. This does not affect the syncs of referrals, marketplace listings or any other functionality, it is only affecting the UI
Posted Jun 26, 2025 - 15:25 UTC
This incident affected: Labra FlyOut (Cloud Marketplace Management) (Dashboard) and Labra OppSync (Cloud Co-sell Management) (Dashboard).