Referrals table

Incident Report for Labra.io

Resolved

The Referrals pipeline is displaying as expected now
Posted Jun 26, 2026 - 07:13 UTC

Investigating

Referral's table is unavailable in Labra UI
Posted Jun 26, 2026 - 07:04 UTC
This incident affected: Labra OppSync (Cloud Co-sell Management) (Dashboard).