Degraded performance due to AWS us-east-1 outage

Incident Report for Labra.io

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 04:44 UTC

Identified

We are currently experiencing service disruptions affecting AWS Marketplace operations in the us-east-1 region(https://health.aws.amazon.com/health/status).
The following operations may be failing or experiencing degraded performance:

- Offer creation
- Resale authorization creation
- Channel Partner Private Offer (CPPO) creation
- Contract confirmations
- Other Marketplace Catalog API operations

Root Cause: The AWS outage is isolated to the us-east-1 region where AWS Marketplace Catalog APIs reside.
Our teams are actively monitoring the situation and working with AWS to restore full functionality.

Normal service will resume once AWS resolves the underlying infrastructure issues.

We apologize for any inconvenience this may cause.

PS: This outage is isolated to AWS marketplace related operations only.
Posted Oct 20, 2025 - 18:59 UTC
This incident affected: Labra FlyOut (Cloud Marketplace Management) (Order processing, Notifications, Public APIs).